Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Martin Sauter

Serious issues with ACP 5.7

When I tried to update ACP to the most recent version 5.7 today, I got an error message saying that I already had the most recent version (which I didn’t).

After this, I got a fatal error which made my WP backend unreachable (not even in revovery mode).

After removing the plug-in through FTP, downloading it again from http://www.admincolumns.com and reinstalling it, it worked as long as I didn’t activate any add-ons.

The Ninja Forms add-on 1.5 (which I have just downloaded) has now the following error message:

This plugin is not compatible with Admin Columns Pro 5.7. It cannot be activated because it might stop the WordPress Admin from working properly. Try updating this plugin to the latest version and then activate it again.

1 month ago
Martin Paff

I also got a hint from WordPress’ automatic pöugiin check:

Fehler-Details
==============
Ein Fehler vom Typ E_ERROR wurde in der Zeile 15 der Datei /var/www/vhosts/happybaby.de/httpdocs/wp-content/plugins/admin-columns-pro/classes/API/Request/ProductsUpdate.php verursacht. Fehlermeldung: Uncaught TypeError: Argument 2 passed to ACP\API\Request\ProductsUpdate::__construct() must be an instance of ACP\Type\ActivationToken or null, instance of ACP\Plugins given, called in /var/www/vhosts/happybaby.de/httpdocs/wp-content/plugins/admin-columns-pro/classes/Updates/Updater.php on line 53 and defined in /var/www/vhosts/happybaby.de/httpdocs/wp-content/plugins/admin-columns-pro/classes/API/Request/ProductsUpdate.php:15
Stack trace:
#0 /var/www/vhosts/happybaby.de/httpdocs/wp-content/plugins/admin-columns-pro/classes/Updates/Updater.php(53): ACP\API\Request\ProductsUpdate->__construct()
#1 /var/www/vhosts/happybaby.de/httpdocs/wp-includes/class-wp-hook.php(294): ACP\Updates\Updater->check_update()
#2 /var/www/vhosts/happybaby.de/httpdocs/wp-includes/plugin.php(212): WP_Hook->apply_filters()
#3 /var/www/vhosts/happybaby.de/httpdocs/wp-includes/option.php(1931): apply_filters()
#4 /var/www/vhosts/happybaby.de/httpdocs/wp-includes/update.php(354): set_site_transient()
#5 /var/www/vhosts/happybaby.de/httpd

1 month ago
Stefan
Developer

We are aware of the issue as stated in this topic:

Update Failed: The plugin is at the latest version.

At this moment, we don’t know why and how this issue (that the plugin is up-to-date) can happen, so any information that can be shared with us as mentioned in the topic above.

The message for the integrations means that you need to update those as well because the older version does not work with Admin Columns Pro 5.7. We have a cross-dependency check that gives you this message instead of an error when both plugins are not compatible anymore.

About the second message, we are aware of that issue and a fix is applied in 5.7 so that this error should not occur anymore when performing an update after 5.7.

1 month ago
Martin Sauter

As I have mentioned, I have just downloaded the most recent version of Ninja Forms add-on, so there is no latest version I could upgrade to. And if I activate Ninja Forms add-on 1.5 with ACP 5.7, I get a reproducable fatal error.

This issue is NOT solved.

1 month ago
Stefan
Developer

I’m afraid there is no solution for the message in the Ninja Forms plugin. Our plugin doesn’t work anymore on the NinjaForms submission table. See the notice about this here:


Unfortunately, there will be no updated version for Ninja Forms that is supported with Admin Columns 5.7.
Since the table in NinjaForms is not built on top of the WordPress list table anymore since version 3.6, our plugin cannot work anymore for NinjaForms. That is why we dropped the support for that plugin and decided not to make the plugin compatible with the latest version of Admin Columns.

As long as you’re not on NinjaForms 3.6, you could work with our integration by installing the latest version of our NinjaForms integration in combination with Admin Columns version 5.6.4.

1 month ago

You must be logged in to reply to this topic.