Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Aaron

Class 'AC_Column_Taxonomy' not found

Our site is trying to update to AC Pro version 4 and are aware of the issues with deploying from Git.
We tried with the latest update (4.0.5) and now get a new error that:
Class 'AC_Column_Taxonomy' not found in /plugins/admin-columns-pro/codepress-admin-columns/classes/Column/Post/Taxonomy.php on line 10

Not sure what the issue here might be. Have the git issues been fixed with the latest updates? Any assistance here would be very helpful. We are also using the ACF plugin.

4 years, 3 months ago
Stefan
Developer

Hi Aaron,

The specified column should be available in the file
/plugins/admin-columns-pro/codepress-admin-columns/classes/Column/Taxonomy.php

Can you check if this file exists in your environment?
And do you have this issue only when you try to update the plugin through WordPress?
Or did you try another method to update the plugin? Do you have the same issue on your local environment?
I need some more information to try to reproduce the issue since I’m not sure whats happening here.

4 years, 3 months ago
Anna

Hi!

Did you guys make this work? I had the same problem. Worked perfectly when I updated the plugin locally (on a Mac). But when I pushed it to our stage environment, I got this error message. I found out it was because I had two columns-folders in
/plugins/admin-columns-pro/codepress-admin-columns/classes/
One columns and one Columns.

I don’t know what went wrong, but I guess my computer didn’t think of the files as changed, and that was why they didn’t get committed and thus creating this error. I moved the files to the right place on the stage environment, it recognized the files as changed, and committed.

4 years, 2 months ago
Stefan
Developer

Hi Anna,

How did you push the files to staging? Did you use Git?
If so, have a look at my last comment in this topic about Git

500 Error on Pro Activation!

4 years, 2 months ago

You must be logged in to reply to this topic.