Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
James Harmer

Weird Error after entering define('WP_ALLOW_REPAIR', true);

Hi I thought I was having issues with my database so I edited my wp-config file to include the line
define(‘WP_ALLOW_REPAIR’, true);
and ever since then I was getting the same line showing on my admin pages. So I deleted it from the config file and it was still on my admin pages. I tried define(‘WP_ALLOW_REPAIR’, false); but it still remained.
I tried uninstalling plugins but kept getting an error that reported this line as a reason to abort the delete command.
I tried everything to remove it and search where it was coming from.
In the end I started turning off plugins one by one and it turns out to be Admin Columns. The allow repair line has become embedded in the plugin or database entries for it?
Anyway I actually really need the plugin but don’t want to loose the columns I have already set up. I have used it to make a lot of custom post column tables. What is the best way to go about fixing it? Shall I save out my custom tables and the reinstall the plugin?
Many thanks for your help in advance, James

1 month ago
Stefan

Hi James,

Thanks for your feedback.
This is a new issue for me and I’m not familiar with the WP_ALLOW_REPAIR line.
But I do know for sure that this is not anywhere in our codebase, so I have no idea how this could be related to our plugin. Sure, you can remove our column and reinstall it. You won’t lose any column settings when doing this because all that is stored in the database.

1 month ago

You must be logged in to reply to this topic.