Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
WP Dev

Version 5.1.0 – plugin activation trows fatal error

hi there,

When updating to your latest version, ig get a Fatal error:
Fatal error: Declaration of AC\ListScreenRepository\DataBase::get_source(AC\ListScreen $list_screen) must be compatible with AC\ListScreenRepository\SourceAware::get_source(AC\Type\ListScreenId $id) in /app/public/wp-content/plugins/admin-columns-pro/admin-columns/classes/ListScreenRepository/Database.php on line 11

i going back to a previous version for now, just to let you know about this error.

1 year, 5 months ago
WP Dev

i managed to solve the issue by replacing the 5.0.3 version to the newer 5.1.0 version.
Replacing files : remove the old plugin (folder), replace with newer version (folder). (not updating trough backend)

1 year, 5 months ago
Tobias
Developer

We changed the ‘DataBase.php’ file to ‘Database.php’. It seems the file was not overwritten when you updated the plugin. This can happen when you are using FTP or Git, and the tool you are using is case insensitive.

When updating the plugin through the WordPress plugin page this won’t happen, because the updater will delete the old files before installing the update.

1 year, 5 months ago
David Nicinski

Where is the Database.php file located?

1 year, 5 months ago
Tobias
Developer

The file is located at: /wp-content/plugins/admin-columns-pro/admin-columns/classes/ListScreenRepository/Database.php

1 year, 5 months ago

You must be logged in to reply to this topic.