Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Justin

Unable to Upgrade Plugin or Add-ons, SSL Error

I am not able to upgrade either the Admin Columns Pro plugin or the ACF addon, both receive similar error messages related to the SSL cert not matching the domain:

Enabling Maintenance mode…

Updating Plugin Admin Columns - ACF add-on (1/2)
Downloading update from https://www.admincolumns.com?wc-api=software-licence-api&request=plugindownload&licence_key=XXXXXXXXXXX&plugin_name=cac-addon-acf…
An error occurred while updating Admin Columns - ACF add-on: Download failed. SSL: certificate subject name '*.wpengine.com' does not match target host name 'www.admincolumns.com'
Updating Plugin Admin Columns Pro (2/2)
Downloading update from https://www.admincolumns.com?wc-api=software-licence-api&request=plugindownload&licence_key=XXXXXXXXXXX&plugin_name=admin-columns-pro…
An error occurred while updating Admin Columns Pro: Download failed. SSL: certificate subject name '*.wpengine.com' does not match target host name 'www.admincolumns.com'
Disabling Maintenance mode…

I am running:

WordPress 4.0 MultiSite
Nginx 1.6.2
PHP 5.4.33

4 years, 8 months ago
Tobias
Developer

I will look into it!

For now you can download the latest version from the “My Account” page.

4 years, 8 months ago
Tom

Same issue with the SSL certification blocking the update?

Any progress?

4 years, 8 months ago
Tobias
Developer

We have just released a fix for this issue in version Admin Columns Pro v3.0.9.

If you can not upgrade automaticly, please get it from “My Account” page. Once you have it installed you will be able to update again from your WP Dashboard.

Our documentation explains how to manual install the plugin: https://www.admincolumns.com/documentation/getting-started/installation/

4 years, 8 months ago
Justin

Hi Tobias,

Unfortunately version 3.0.9 did not work for me either, the problem seems to be with the WP Engine server configuration, not your plugin. On some systems it is trying to use SSLv3, and for this encryption the WP Engine server returns a cert for *.wpengine.com rather than http://www.admincolumnspro.com.

As I managed a bunch of sites, and may of them run ACP, manually updating is a bit of a pain. I use a management too to remotely update things whenever I can, plus doing it manually means I wipe out my SVN configuration for that directory as well (I have a plugin that keeps it in sync if I use the WordPress API). That said, I was able to work around this by filtering the WP_Http request and turning off the SSL certificate verification if the request was for an ACP plugin.

I wrote up some of the research that I did and posted some sample code to allow sites disable the SSL cert validation for ACP Updates. See the post here: Admin Columns Pro SSL Upgrade Fix

4 years, 7 months ago
David
Developer

Hi Justin,

Thanks for your input on the forum and the chats. For those who have had this issue too: we have made several improvements on how Admin Columns Pro handles secure connections. We implemented Justin his suggestion. We try to detect it automatically and when problems occur, it will toggle (true/false) the sslverify option.

We also have a dedicated IP address now for admincolumns.com. We had another WordPress installation on the same IP and this caused some servers to give an error on the validation the secure connections.

4 years, 6 months ago

You must be logged in to reply to this topic.