Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Jack Hughes

The Events Calendar plugin conflict – Bulk Actions

Greetings,

I am using Admin Columns 4.7.2 with The Events Calendar 4.9.8 and The Events Calendar plugin for Admin Columns 1.4.1 in WP 5.2.3.

Situation:
I need to trash a bunch (hundreds) of TEC events using TEC Bulk Actions. I will select all the events then in Bulk Actions I select “Move to Trash” and apply. After working a bit I get this message: “error moving to trash”. I then go back to the events list in TEC and see that only some of the events were moved to trash. Example: 61 of them instead of 151.

My server error log shows the following:
GET /wp-admin/edit.php?orderby=5d6707f5c83fa&order=asc&s=&post_status=publish&post_type=tribe_events&_wpnonce=ab76637ac5&_wp_http_referer=%2Fwp-admin%2Fedit.php%3Forderby%3D5d6707f5c83fa%26order%3Dasc%26s%26post_status%3Dpublish%26post_type%3Dtribe_events%26m%3D0%26acp_filter%255Bevents-cats%255D%3Dhistoric-trolley-tours%26paged%3D1&m=0&acp_filter%5Bevents-cats%5D=historic-trolley-tours&action=trash&paged=1&post%5B%5D=1849&post%5B%5D=1851&post%5B%5D=1945&post%5B%5D=1852&post%5B%5D=1957&post%5B%5D=1853&post%5B%5D=1958&post%5B%5D=1854&post%5B%5D=1959&post%5B%5D=1855&post%5B%5D=1960&post%5B%5D=1856&post%5B%5D=1961&post%5B%5D=1857&post%5B%5D=1962&post%5B%5D=1858&post%5B%5D=1963&post%5B%5D=1859&post%5B%5D=1964&post%5B%5D=1860&post%5B%5D=1965&post%5B%5D=1861&post%5B%5D=1966&post%5B%5D=1862&post%5B%5D=1967&post%5B%5D=1863&post%5B%5D=1968&post%5B%5D=1864&post%5B%5D=1969&post%5B%5D=1865&post%5B%5D=1970&post%5B%5D=1866&post%5B%5D=1971&post%5B%5D=1867&post%5B%5D=1972&post%5B%5D=1868&post%5B%5D=1973&post%5B%5D=1869&post%5B%5D=1974&post%5B%5D=1870&post%5B%5D=1975&post%5B%5D=1871&post%5B%5D=1976&post%5B%5D=1872&post%5B%5D=1978&post%5B%5D=1873&post%5B%5D=1979&post%5B%5D=1874&post%5B%5D=1980&post%5B%5D=1875&post%5B%5D=1981&post%5B%5D=1876&post%5B%5D=1982&post%5B%5D=1877&post%5B%5D=1983&post%5B%5D=1878&post%5B%5D=1984&post%5B%5D=1879&post%5B%5D=1985&post%5B%5D=1880&post%5B%5D=1986&post%5B%5D=1881&post%5B%5D=1987&post%5B%5D=1882&post%5B%5D=1988&post%5B%5D=1883&post%5B%5D=1989&post%5B%5D=1884&post%5B%5D=1990&post%5B%5D=1885&post%5B%5D=1991&post%5B%5D=1886&post%5B%5D=1992&post%5B%5D=1887&post%5B%5D=1993&post%5B%5D=1888&post%5B%5D=1994&post%5B%5D=1889&post%5B%5D=1995&post%5B%5D=1890&post%5B%5D=1996&post%5B%5D=1891&post%5B%5D=1997&post%5B%5D=1892&post%5B%5D=1998&post%5B%5D=1893&post%5B%5D=1999&post%5B%5D=1894&post%5B%5D=2000&post%5B%5D=1895&post%5B%5D=2001&post%5B%5D=1896&post%5B%5D=2002&post%5B%5D=1897&post%5B%5D=2003&post%5B%5D=1898&post%5B%5D=2004&post%5B%5D=1899&post%5B%5D=2005&post%5B%5D=1900&post%5B%5D=2006&post%5B%5D=1901&post%5B%5D=2007&post%5B%5D=1902&post%5B%5D=2008&post%5B%5D=1903&post%5B%5D=2009&post%5B%5D=1904&post%5B%5D=2010&post%5B%5D=1905&post%5B%5D=2011&post%5B%5D=1906&post%5B%5D=2012&post%5B%5D=1907&post%5B%5D=2013&post%5B%5D=1908&post%5B%5D=2014&post%5B%5D=1909&post%5B%5D=2015&post%5B%5D=1910&post%5B%5D=2016&post%5B%5D=1911&post%5B%5D=2017&action2=-1 HTTP/1.1

NOTE: If I deactivate Admin Columns, I am able to properly use “Move to Trash” TEC bulk action.

1 week, 1 day ago
Stefan
Developer

Hello,

I tried to reproduce the issue, but removing 200 events at the same time, but everything seems to be working fine on my end. Based on your screenshot, I see that you also sorted on a column on the overview and that you were filtering the overview. Since only a few of your items were removed, I think your server ran into a timeout. It could be caused by the fact that the overview was ordering the items, so you could try to reset sorting by clicking the ‘Reset Sorting’ button on the overview and try it again.

Since I really suspect this is a resource problem, just trying some things out with fewer filters, no sorting and removing fewer items at once is what could fix this issue on your environment.

1 week ago

You must be logged in to reply to this topic.