Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
admin.it

Plugin page not loading

Hi,

We have a custom post type with 33k+ entries that we are adding the extra columns.
There are currently 12 columns set. To access the plugin page and update this columns takes me aprox. 60 seconds.
While the Admin Columns Settings page is loading, the whole backend is not responsive.

Is this behavior expected. Is there anything I can do to decrease the loading time?

3 years, 5 months ago
Stefan
Developer

Hi,

Our plugin can increase loading times on environments with large datasets (like yourself), especially when you have columns active with complex values and sorting and filtering active. Unfortunately, there is not much we can do about this, since all values must be retrieved per records, per column, that’s the way WordPress works.

You could try the following to make the overview page respond faster

1) Show fewer records on the same page through the screen options menu (right top)

2) See if sorting is active on your overview page. If that is the case, hit the ‘reset sorting’ button and see if the page loads any faster. If it does change loading times, then sorting for that column may have been the culprit.

3) If you see the page but the page is not responsive. It may be because the filtering drop-downs have that many records, that the page won’t load. For example, the filter drop-downs contains all the possible values for that column. So if you have a filter for a column where every row has a different value, then you have 33k+ options for that drop-down. That’s definitely not something our plugins is made for and a search plugin to find records on the overview might be a better solution for you. We do cache the results for the dropdowns for some seconds, but increasing this time, might decrease the loading times on this page. You can try the following snippet on your website.

/**
 * @param                     $seconds
 * @param ACP_Filtering_Model $model
 */
function acp_filtering_cache_seconds( $seconds, $model ) {
	return 200;
}

add_filter( 'acp/filtering/cache/seconds', 'acp_filtering_cache_seconds', 10, 2 );

This last point may also be the cause for your column settings page that does not respond. If you have a lot of different custom fields. it could take a while before the drop-downs for the custom field columns are loaded. Or maybe you have a JS error on this page that is preventing our page from responding.

3 years, 5 months ago

You must be logged in to reply to this topic.