Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Alvaro

Performance 30000 post

Hi,

We have in the database 30.000 posts , about 300 per user.

When a user login in his account and navigate with multiple pages about his posts without filter, the perfomarce is good, but when I order by 1 column, the performance down a lot. (from 1 or 2 second, to more that 10 seconds for change the page), I tested with view 10 post/page and 40 post/page with the same behaviour. Seems that is ordering all the post and then filter by user for show it. Is strange because how I say.. when not filter is or ordering is selected the navigation pages is fine.

Can you hellp me?

Alvaro

4 years, 8 months ago
Stefan
Developer

Hi Alvaro,

We are aware of this issue and this should be fixed in our upcoming release 3.6.1.
The planning is to release this update this week, so please be patient. We would really appreciatie it if you could reply on this post with the testresults when you’ve tested the new release :)

4 years, 8 months ago
Tobias
Developer

We have released version 3.6.1 today, you can upgrade from either your account or plugin page. Hopefully this release will fix your issue.

4 years, 8 months ago
Alvaro

Hi TObias,

I have installed the 3.6.1 and the perfomance is the same poor.

We have in the database 30.000 posts , about 100 to 300 posts per user.

Viewing in 6 -7 pages for 20post/page, it get 21 second for change a page, or for apply an order.

Whithout filters or orders the change page is about 2 seconds.

I’m developing in localhost for this web, so the general performance of the server is good.

Any ideas? I have to do anything more in the config of the plugin?

Alvaro

4 years, 8 months ago
Alvaro

by the way, all the columns that I want to see, that are in my table view are advanced custom fields…

ALvaro

4 years, 8 months ago
David
Developer

Hi,

I will look into this for you. Expect an update tomorrow. Can I pm you if I need additional information about your installation?

Best, David

4 years, 8 months ago
Alvaro

Ok, thank you, no problem.

Alvaro

4 years, 8 months ago
Alvaro

Hi David,

I installed the version 3.6.2 and is the same.

The filter option is good and for filter and navigate with pages of data the performance is good, about 1 or 2 seconds.
But the order option not.

Same values:
Database 30.000 posts , about 100 to 300 posts per user.

I’m testing one user has 119 elements.
Viewing in 6 pages for 20post/page, it get 30 second for change a page, or for apply an order in a column.

All elements to see are advanced custom columns, and the order is order by number bill.
Example:
https://dl.dropboxusercontent.com/u/61450114/capture.png

Thanks in advance

Alvaro

4 years, 8 months ago
Alvaro

Hi guys,

any advance?

Alvaro

4 years, 8 months ago
David
Developer

I have send you a pm, so we can just post the outcome here for other users to read.

4 years, 8 months ago
Alvaro

Hi David,

I write you to the email, but I write also here for continuity.

I installed the last version of Admincolums 3.7.1, and ACF 1.3.3. and the problem with he performance with the order the columns continues.

I remember that we have …

Same values:
Database 30.000 posts , about 100 to 300 posts per user.

I’m testing one user has 119 elements.
Viewing in 6 pages for 20post/page, it get 30 second for change a page, or for apply an order in a column.
If I not sort the page load fine 1 to 3 seconds.
If I filter the page load fine 1 to 3 seconds.

So the problem is in the order by a column, it takes more that 30 seconds to order, filtered or not filtered.

I have filtered with 4 results, and it take the same time.

This problem continue from the 1rt version, and you said me the in this version would be fixed. :(
Thanks,

Alvaro

4 years, 6 months ago
David
Developer

Hi Alvaro,

Thanks for contacting us about this. We have not forgotten about it: https://github.com/codepress/admin-columns-issues/issues/299

However, WordPress 4.4 made a lot of changes and we needed to release to make Admin Columns compatible with that release. The good news: there is a patch and we are testing it currently. As soon as we have this functionality in beta, I will send you that version for you to test.

I’ll be in touch soon.

4 years, 6 months ago
Alvaro

Thank you David,

appretiate, my client is a litle …anxious.. ;)

Alvaro

4 years, 6 months ago
Alvaro

Hi David,

any advance?
when you have planned to publish it?

could you send me the patch for try in my site?

Alvaro

4 years, 5 months ago

You must be logged in to reply to this topic.