Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Philippe

pages lists only 20 from 32

With Admin Columns Pro enabled, WP only displays the first 20 IDs from 32 published Pages in the admin post_type=page listing, which makes for some quite fascinating hierarchy hide-and-seek, but still is somewhat less than practical.
I can’t think of any setting I’d have to change in ACP for all the pages to display again.
What am I missing here?

4 years, 8 months ago
Stefan
Developer

Hi Philippe,

20 items is the default setting for items in a list view in WordPress. The number of items is used in ACP but we always look at the setting that is used in the overview. Can you tell me what the value is of the ‘number of items per page’ field in your screen option overlay? (in the right top on your page).

Another question, is paging working for your overview? Or do you only have 1 page with 20 items?

4 years, 8 months ago
Philippe

Hi Stefan,

the thing is: when ACP is enabled here, my Pages listing in the WP Backend does not do any paging (numbers at the top any bottom of anymore.
Of course I can set the maximum ‘number of items per page’ in the overview to 40, or so, but that’s not a solution in my eyes.

I tried manual paging, adding /wp-admin/edit.php?post_type=page&paged=2 but it always automatically switches back to &paged=1.

On every other type of post (4 custom post types plus WP posts), paging in overviews work without a problem.

Thanks, Phil

4 years, 8 months ago
Philippe

Hi Stefan

FYI: I just noticed this only happens on my local MAMP dev server, so I guess it’s not too bad of a problem.
Anyway, I’ll try to add two screenshots so you can see what I mean.

Thanks, Phil
ACP OFF: paging works
ACP ON: no paging

4 years, 8 months ago
David
Developer

Hi Phil,

It seems your screens did not make it :)

Can you make sure you have the latest versions of ACP and WordPress? What version of PHP / Apache is your MAMP? Maybe it is something that only happens in a certain version of PHP that we can find out.

Best, David

4 years, 8 months ago
Philippe

Hi David

MAMPs PHP default is 5.6.10; WP is 4.3.1 and ACP 3.6.1.
I’ve just tried switching PHP to 5.5.26 – still the same result.

My guess is it’s a combination of factors, not least of which is that there were hundreds of pages on this site before I converted most of them to various Custom Post Types.

I’ll try ACP on a different MAMP local server later, see if the same bug shows up.

Thanks, Phil

(BTW: opening the screenshots links directly should work – they’re on DropBox.)

4 years, 8 months ago
David
Developer

I can see your screenshots now via de Dropbox link. Thanks.

It must be something, but it’s hard to tell what it is. Have you gotten to setup a different MAMP server yet? It’s all Windows right?

4 years, 8 months ago

You must be logged in to reply to this topic.