Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Aurélien

Not allowed to access settings

Hi,
since a couple of days I’ve noticed that I can’t access Admin Columns Pro settings anymore. I get the WP notice:
Sorry, you are not allowed to access this page.

Already tried to disable all plugins, remove mu-plugins and revert back to default theme without success…

4 years, 8 months ago
Stefan van den Dungen Gronovius
Developer

Hi,

Did you maybe install a role manager or other plugin that manages capabilities?
In order to manage the column settings, you’ll need to have the capability ‘manage_admin_columns’.
It does sound like that your user account does not have this specific capability anymore.
And since it happens for a couple of days, I would suspect that there was something on your environment that has triggered it.

4 years, 8 months ago
Aurélien

Hi Stefan,

I added the capability you mentioned manually using User Role Editor and it works fine again.

The weird thing is that everything was working fine with User Role Editor for a while. I also tried to reset everything but it doesn’t work. :/

4 years, 8 months ago
Stefan van den Dungen Gronovius
Developer

I’m glad it works again.
I have no idea how and why the capability was removed from your user, but I suspect it has something to do with the role editor. By default, we set our capability enabled for Admins as long as it is not overwritten by another capability plugin.

4 years, 8 months ago
Roger

Hi! I have the same problem with a new installation. How can I add the capability manage_admin_columns ? I have the Admin Role and it’s the first time this happened. Thanks for your support.

3 months ago
Roger

Sorry, just found out by myself. For others who are looking for the same.
Add these lines once in the functions.php and reload the page. This updates the user capabilities. After that you can delete the lines:

$admin_role = get_role( ‘administrator’ );
$admin_role->add_cap( ‘manage_admin_columns’, true );

3 months ago

You must be logged in to reply to this topic.