Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
cblack

Invalid composer credentials

Hi,

Just recently our composer installs started failing with
Invalid credentials for 'https://composer.admincolumns.com/packages', aborting.

I’ve tried:
– Generating a new composer api token.
– Clearing composer cache and deleting .lock file and plugin.

Relevant parts of our composer.json:


{
  "repositories": {
    "admin-columns": {
      "type":"composer",
      "url":"https://composer.admincolumns.com"
    }
  },
  "require": {
    "admin-columns/ac-addon-acf": "*",
    "admin-columns/admin-columns-pro": "*",
  }
}

Relevant parts of auth.json:


{
    "bearer": {
        "composer.admincolumns.com": "xxx"
    }
}

Our installs have worked for a long time with this configuration and have only started failing recently. Any help would be appreciated.

1 year, 2 months ago
cblack

I’ve also attempted using the user/password authentication for composer but get the same result. Our license is confirmed to still be active.

1 year, 2 months ago
Stefan
Developer

Thanks for letting us know.
It seems that there were some changes in our layer of protection and the composer server was not updated correctly. We changed it and it seems to work correctly again.

1 year, 2 months ago

You must be logged in to reply to this topic.