Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Hidehiro

Inline Edit with Datepicker

Dear Developer

It seems Inline Edit with Datepicker do not work.
After editting , the display of date will change to “1970/01/01”.
Please check with the configuration as follows.

1.Advanced Custom Field
(1)Field Type: Date Picker
(2)Display format:yy/mm/dd

2.admin columns pro
(1)Data format:WordPress Date Format Y/m/d

4 years, 4 months ago
David
Developer

Hi,

Do you know the versions of ACF, Admin Column Pro (and the add ons) and WordPress you are using? We’ll try to reproduce the issue with that information.

What I can tell you is that the most recent versions of Admin Columns Pro and the add ons with ACF version 5 should not have any issues. But, maybe you found one that we need to fix.

4 years, 4 months ago
Hidehiro

Hi David,

The Version of my environment are as follows.

WordPress:4.7.4ja
Admin Columns Pro:4.0.4
Admin Columns – Advanced Custom Fields add-on:2.0.3
Advanced Custom Fields:4.4.11

Regards,

Koichi

4 years, 4 months ago
Stefan
Developer

Hi Koichi,

I was not able to reproduce the issue with the plugins you mentioned.
Can you tell me what save format you have for your ACF date field?
By default it is ‘yymmdd’ but maybe you have another format.
And the you’ve set the display setting in the column to Y/m/d, correct?

4 years, 4 months ago
Hidehiro

Hi STEFAN,

I am using Japanese Version.
And my Setting is as follows.

1.Advanced Custom Fields
フォーマットを保存する yy/mm/dd <–(1) not default
表示フォーマット yy/mm/dd <–(2) not default

2.Admin Columns Pro
データフォーマット WordPress Date Format Y/m/d

I think that the reason of this situation is (1).

4 years, 4 months ago
Stefan
Developer

Hi Koichi,

I was able to reproduce the issue with the provided information and already made a fix for the upcoming release.
The fix will probably released today.
Thank you very much for your input for this issue.

4 years, 4 months ago
Hidehiro

Hi STEFAN,

Thank you for your quick response.
I am glad to hear that you were able to reproduce the issue and already made a fix.
I am looking forward to releasing the fix version.

4 years, 4 months ago
Stefan
Developer

You should be able to download the latest version with the fix right now.
Please let me know if this fixes your problem.

4 years, 4 months ago
Hidehiro

Hi STEFAN,

Thank you for an announce about the release of the latest version.
Now I have checked it. but …
It seems that it is Not fix completely.
A value of date field dose not match a value of datepicker.
Please check with the following step.

1.Set a value of date field to “2017/05/01” with inline editing.
2.Change to another page or logout.
3.Return to a page overview.
4.Click inline editing icon to display datepicker.
5.You will find a value of datepicker does not match a value of date field.
(datepicker will display Today.)

4 years, 4 months ago
Stefan
Developer

Hi Koichi,

I’ve send you a copy with a fix. Can you let me know if this fixes the problem.
Then the fix will be available in the upcoming maintenance release.

4 years, 4 months ago
Hidehiro

Hi STEFAN,

I have finished a check of datepicker with my custom fields.
I can NOT find out new problems.
So I think the problem is fix.
Please be the fix available in the upcoming maintenance release.

4 years, 4 months ago
Stefan
Developer

Hi Koichi,

Thanks for testing. We’ll make sure the fix will be applied to the next maintenance release.

4 years, 4 months ago

You must be logged in to reply to this topic.