Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
William

Filter By

Hey Andreas…I ran into something really odd today. First off, Due to the amount of posts I have in the 4 custom post types I utilize on my site (26k plus on one of them, 14k plus on another..etc), I tend to set up my extra columns when I need to do a particular editing activity (things like excerpts and content really slow down editing refreshes on the admin side).

Anyway, the other day I was filtering by a custom field “wpcf-city”, without issue. Today I revisited the city filter, only to find that when I turned on filtering, that it was picking up data from other custom fields and ignoring the wpcf-city data.

Just went back into admin so I could check a couple of things while writing up this ticket. The issue was gone on the first and second custom post types. Then I went to a third custom post type,”resource_links” (which is one of my smaller ones with about 1400 posts) and when I turned the filter on for the wpcf-city custom field, it was again pulling in the wrong data from a different field.

Earlier today, and on this last check, I experimented and added/removed columns…and the wpcf-city filter would also change which field it was pulling data from…most of the time a taxonomy field, but a few times from a wpcf-dealer-statement field too.

So I went back to the “resource_links” custom post type, tinkered with it for a bit and added a second column dedicated to the “wpcf-city” custom fields(u understand…I had two columns dedicated to it). After I did this, the filter worked properly!!

I’m wondering if this is a cache issue?

I’m running Nginx w/ FastCGI Cache on an Apache linux server. Also using ConfigServer eXploit Scanner cxs for security purposes.

Any thoughts on this?

Regards,
Will

5 years, 1 month ago

You must be logged in to reply to this topic.