Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Georgi

Fatal error: Maximum execution time of 30 seconds exceeded

Hello. I have a site with more than 13000 posts and want to sort them by Word Count and to delete the thin content. But there is a problem:

Fatal error: Maximum execution time of 30 seconds exceeded in (…) /public_html/wp-content/plugins/admin-columns-pro/admin-columns/classes/Helper/Strings.php on line 63

The same plugin works fine on the other 4 licensed sites located on the same server. Should I increase the execution time and how to do that? (I am not good at coding).

3 weeks, 6 days ago
Stefan
Developer

Hi there,

Some columns are not really optimized for sorting. In order to sort on the word count, we first have to determine the word count of each post. So on a large dataset, this could really be a slow process.

To be honest, increasing the execution time could help, but I think that it is not preferable to wait that long for an overview to load. The sorting logic for this column is just not optimized for large datasets and probably won’t ever be.

So in this case, I advise you not to enable sorting for this column. There are more columns that are not optimized for large datasets and I think we have to make that clear somehow to the users.

3 weeks, 2 days ago
Georgi

Thank you very much! Have a good day!

3 weeks, 2 days ago

You must be logged in to reply to this topic.