Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics

Export Functionality not working 100%

For a custom post type I have the following admin columns (screenshot;

– Featured Image
– Title
– Taxonomy
– Date
– Permalink

..and it’s working fine to export (fixed in version 3.2 I think?). But there are some problems.

1. The Admin Column Settings such as “Enable filtering”, “Enable sorting”, “Enable editing” don’t function. I can see that the export file (php) clearly states these properties, but once imported – they are default. So you have to manually change these.
2. When adding a “Taxonomy” column, these dont work when imported. You have to manually “Update” the rules for it to start working (and by working, I mean show up at all).

That’s all I have now.

9 years, 6 months ago
Tobias Schutter

I will have a look and get back to you. Thank you for the bug report.

9 years, 6 months ago

Thanks man.
Btw, when I have you on (without filing another issue): Now I somehow can’t get the import to work properly.. Not sure why it stopped working, but I did hit the “Restore default settings”-button under Settings. It’s working on my local environment, but the database on the production may be “corrupt”.

Question: Do you have any instructions on how I remove everything that has to do with “Admin Columns” from the database? So I can start of clean. I didn’t back up the database. It seems like you store the data in wp_options.

9 years, 6 months ago
Tobias Schutter

The issue with PHP export has been solved, this fix will be in the next release.

The “Restore default settings” deletes all stored columns data. The only thing that remains are the few general options, like “show edit column” etc. If you want to remove those aswell you could run this once:

delete_option( 'cpac_general_options' );

That will completely remove all DB data that has been set by Admin Columns.

Could you mail me the export file (txt) of your columns settings? Maybe I can reproduce the issue that way.

9 years, 5 months ago

You must be logged in to reply to this topic.