Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the community forum?
All Topics
Dirk

Duplicate column breaks plugin

I accidentally added a duplicate column and I got an error message. I thought I had deleted it, but it didn’t delete and I get the following error:

PHP Fatal error: Cannot declare class AC_Column_Post_Parent, because the name is already in use in /nas/content/live/domain/wp-content/plugins/admin-columns-pro/admin-columns/classes/Column/Post/Parent.php on line 10, referer: https://domain.com/wp-admin/edit.php?orderby=date&order=asc&s&post_status=pending&post_type=ad_listing&action=-1&m=0&acp_filter%5Bcolumn-taxonomy%5D&acp_filter%5B595970d779591%5D&acp_filter%5Bcolumn-status%5D&acp_filter%5Bcolumn-meta-1%5D=Y3BhY19lbXB0eQ%3D%3D&acp_filter%5Bdate%5D&acp_filter-min%5Bcolumn-meta-2%5D&acp_filter-max%5Bcolumn-meta-2%5D&_ac_nonce=7efe9f8bb8&layout=59dfb2bfa9815&filter_action=Filter&paged=1&action2=-1

I’m on version 4.3.8

Where is the setting data stored so I can replace from a backup?

5 months, 4 weeks ago
Dirk

I restored the site from a backup to mitigate this. I then updated to 4.5.7 but am having CSS issues where the filters are being hidden. When I tried to revert to the old version, I got this error again.

5 months, 3 weeks ago
Stefan
Developer

Hello Dirk,

Reinstalling the plugin should fix this problem.
The file that is trying to load should not exist anymore in the plugin folder.
Can you explain to me what you mean with ‘the filters are being hidden’?
Maybe this is a cache issue on your environment?

5 months, 3 weeks ago
Dirk

Sorry for the late response, I’m having trouble receiving your emails again.

The dropdown controls to filter the columns briefly appear and then get hidden, likely with CSS. We are also having issues with CSS changes causing fields with long values to overflow into the next column on top of other values rather than wrap like the older version did.

4 months, 4 weeks ago
Stefan
Developer

Hi Dirk,

Could you contact me on support@admincolumns.com?
I would like to have a look at your environment to so see what’s happening with the drop downs.
I know that we changed this behavior, so I suspect that it is a caching issue, but there might be something else that might be interfering here.

4 months, 3 weeks ago

You must be logged in to reply to this topic.