Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
lance3

Critical Error > WooCommerce Product Admin

Hi Support,

We have WooCommerce enabled as well as AdminColumnPro. When I visit dashboard > products the page returns a critical error. Upon checking the error log, i see the following:

[11-Jan-2023 01:10:59 UTC] PHP Fatal error:  Uncaught TypeError: ACP\ConditionalFormat\Service\Assets::sanitize_column_label(): Argument #1 ($label) must be of type string, null given, called in /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php on line 75 and defined in /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php:88
Stack trace:
#0 /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php(75): ACP\ConditionalFormat\Service\Assets->sanitize_column_label(NULL)
#1 /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php(63): ACP\ConditionalFormat\Service\Assets->get_column_label(Object(ACA\ACF\Column))
#2 /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php(123): ACP\ConditionalFormat\Service\Assets->get_columns(Object(ACA\WC\ListScreen\Product))
#3 /wordpress-versions/6.1.1/wp-includes/class-wp-hook.php(310): ACP\ConditionalFormat\Service\Assets->ACP\ConditionalFormat\Service\{closure}(Object(ACA\WC\ListScreen\Product))
#4 /wordpress-versions/6.1.1/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
#5 /wordpress-versions/6.1.1/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
#6 /wp-content/plugins/admin-columns-pro/admin-columns/classes/Table/Screen.php(271): do_action('ac/table_script...', Object(ACA\WC\ListScreen\Product), Object(AC\Table\Screen))
#7 /wordpress-versions/6.1.1/wp-includes/class-wp-hook.php(308): AC\Table\Screen->admin_scripts('edit.php')
#8 /wordpress-versions/6.1.1/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
#9 /wordpress-versions/6.1.1/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
#10 /wordpress-versions/6.1.1/wp-admin/admin-header.php(118): do_action('admin_enqueue_s...', 'edit.php')
#11 /wordpress-versions/6.1.1/wp-admin/edit.php(407): require_once('/wordpress-vers...')
#12 {main}
  thrown in /wp-content/plugins/admin-columns-pro/classes/ConditionalFormat/Service/Assets.php on line 88

Please could you provide some direction on how we could resolve?

3 weeks, 3 days ago
Stefan
Developer

It seems that one of the columns on your product page has an invalid label.
Can you create a copy of your column set and remove the column one by one to see which column causes the issue?
Once you have found the column, can you share the column type or a screenshot of the settings for that column with me? Can you send it to support@admincolumns.com?

3 weeks, 1 day ago

You must be logged in to reply to this topic.