Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Bruce2

Can’t Add New thru inline editing for custom taxonomy

Hello! I have created two custom taxonomies, Media Categories and Media Tags.

In Admin Columns, I have added them to the Media Library view, and turned on Inline Editing. I also turned on the ability to Add New.

If I have already added a category or tag through their respective pages, I can add them to a media item via inline editing. But, I cannot add a new media category or media tag via inline editing. I click the check box, the dash goes yellow for a second, and then nothing.

Thoughts?

9 months, 1 week ago
Stefan
Developer

Does this issue even persist when you refresh the page?
I just tried to reproduce the issue on my local environment, but the ‘Add new’ function works correctly when I try it. Maybe the feedback (flashing) was incorrect but the tag was saved correctly for the post.

And when you select existing tags/categories, does it work as expected?

9 months, 1 week ago
Bruce2

OK, I figured it out. Perhaps my fumbling can help someone else.

When I entered a new term, the field showed the term below as if it had found it in a search. (Which, when I think about it, is what it should do, in case the term wasn’t actually new.)

When I saw the term pop up below, I ignored it, since I knew it was new and couldn’t have been found. I just clicked the check mark to add it.

THAT was my mistake. Even though the term showed up as if it existed in the list, even though it didn’t, I needed to select it as if it did already exist, THEN click the check mark. When I did that, it worked.

So, all is good now. And once again, I’m glad I use Admin Columns Pro.

9 months, 1 week ago

You must be logged in to reply to this topic.