Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Chris Wiegman

I should add that this is with the latest versions of all applicable plugins and WP Core

1 month, 4 weeks ago
Stefan
Developer

Hi Chris,

Can you also send me a screenshot of your Pod settings for that field?
I like to know what type of field is used in order to see how our Sorting should work.

1 month, 3 weeks ago
Chris Wiegman

Stefan, I’ve tried replying to this twice. If you can’t have it (this is cache or something) please feel free to drop me an email or something else so I can send it some other way.

1 month, 3 weeks ago
Stefan
Developer

Thanks for the input.
I was not able to reproduce the issue on my local environment with the settings you used for your field.
Can you maybe install the plugin ‘Query Monitor’ and analyze the main query.
Do you maybe have any hooks in your theme related to the main query altering the meta_query or sorting yourself?

1 month, 3 weeks ago
Chris Wiegman

Hi Stefan,

Sorry for the late reply as I gave it to this morning so I could properly troubleshoot.

I’ve turned off all plugins sans Debug Bar and Query Monitor (plus required Pods and ACP plugins). I’ve reset the theme to 2022 and I’ve cleared all applicable caches including all transients and I still cannot sort by any Pods fields. Query Monitor shows nothing unusual when I try, it just doesn’t work. Any other ideas?

1 month, 2 weeks ago
Stefan
Developer

Do you maybe have a staging environment where I can see this in action?
If so, please share any details with me at support@admincolumns.com.

1 month, 2 weeks ago
Chris Wiegman

Sure, I’ll get that updated at some point this week and send the creds over. I’ll let you know when I’ve completed that. Thank you, Stefan.

1 month, 2 weeks ago
Chris Wiegman

I’ve setup a staging site and emailed the creds (with a link to this chat) to the support email.

1 month, 2 weeks ago
Stefan
Developer

Thanks for the information. I replied by email.
We came to the conclusion that our filtering and sorting logic in combination with Pods table storage does not work.
Unfortunately, there is no workaround for that at the moment.

1 month, 2 weeks ago
Steve Beliveau

Hi, I am actually having the same problem except with Metabox. Same issue where when I sort, it just returns empty results. Is this similar to Pods where there is no workaround?

1 month ago
Stefan
Developer

@steve The issue with pods is that we don’t support the Table Storage feature in Pods.
In our MetaBox integration, we have support for sorting on table storage fields.
If that does not work for your environment, please contact me at support@admincolumns.com with some screenshots of your column settings and table page so we can try to figure out what’s happening on your environment.

1 month ago

You must be logged in to reply to this topic.