Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
Sean

ACF fields not appearing on Posts screen when using add-on to limit user access

This may be beyond the scope of what you can help me with but hoping you might have a suggestion.

I’m using Admin Columns Pro along with the ACF add-on. I have an ACF field called “Grade” that I’ve added as a column on my posts screen, and it appears there correctly for me as an admin. However, I’m also using the View Own Posts Media Only add-on to limit the ability of my users to view posts other than their own. The content of the ACF Grade column does not appear for them on the posts dashboard (The column title does, just not the field itself). When I deactivate the View Own Posts add-on the column does appear, so I’m guessing that’s what is interfering but I need to be able to lock down my user’s access.

Any help/suggestions would be appreciated. Thanks!

3 years, 10 months ago
Stefan
Developer

Hi Sean,

Thanks for your feedback. I understand the problem but I’m afraid it’s not something we can fix. The View Own Posts Media Only (VOPMO) plugin hooks into the main query and filters all posts for the specific user. This normally works great for that overview page because no other main queries are run.

But since we use the get_field() function from ACF to render the value of the columns, the filter from VOPMO also fires for those queries. I believe it is because the get_field() is also considered to be a main_query. So maybe you can address this issue to VOWPMO and see if they can make some changes in their code.

3 years, 10 months ago
Sean

Hi Stefan – I just checked the settings screen on VOPMO and it already has an option to allow ACF fields to pass through their query. That appears to be working for me. Thanks for your help!

3 years, 10 months ago
Stefan
Developer

Thanks for the feedback! I’m pleasantly surprised that they build in that support. Seems like they know what they’re doing. Or they had this question before ;) Great it solved your problem. I will close this ticket.

3 years, 10 months ago

You must be logged in to reply to this topic.