Support

Search results for ""

Sorry, no results found. Perhaps you would like to search the documentation?
All Topics
admincolumns19

AC not being loaded for role

Hi. Hope you’re doing well.

I’m using WCMp and when I’m in the “vendor” role, the AC is not displayed in the product list.

I performed some tests, disabling all plugins and noticed that the AC was only loaded when I accessed the link:
wp-admin/edit.php?layout={CODE_HERE}&post_type=product
If I don’t enter this variable “layout”, it doesn’t load. It doesn’t seem to find any views.

After I accessed it the first time, it opens normally the next time.

Can you help me?

1 month ago
Stefan
Developer

Do I understand you correctly that when you say AC does not load, that you have the default columns instead of any saved column sets? And does this only happen for the specific Role you mentioned?
Do you maybe only have column sets that are limited to certain roles?
Can you send me a screenshot of your column sets to support@admincolumns.com so I can help you further there?

1 month ago
admincolumns19

Hello Stefan. Hope you’re doing well.

It would be difficult to notice the “error” by screenshot. If you prefer, I can send a video or staging access.

…you have the default columns instead of any saved column sets?

Yes, but not only. Filters and all admin columns fields are not loaded. I’ve noticed that admin columns JS isn’t even being included.

Do you maybe only have column sets that are limited to certain roles?

Yes, but I’ve added this role as authorized.

In fact, it just works again when I access product list URL with GET parameter “&layout={anycodehere}”. It seems to be the trigger to load AC and include scripts. After I access it, the problem is solved and doesn’t happen anymore, even if I remove “layout” param.

So my question is: when I access products default view and current user role is not authorized. Does it searches for the next view where current user role is authorized?

1 month ago
Stefan
Developer

Yeah, sure please send me a video, that would help.
And yes, then you visit the default page, it should search for the first available layout that is available for the current user. It is strange that the Javascript is not even loaded, as if it does not recognize the page at all as an available list page for that role.

1 month ago
admincolumns19

Hello Stefan

I sent you the video by email.
Subject: “AC not being loaded for role”

1 month ago

You must be logged in to reply to this topic.